В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
luizazamanov
luizazamanov
03.07.2022 03:14 •  Информатика

Решить программу на pascal abc. с random и : найти количество четных чисел из 20 целых случайных чисел из любого интервала.

Показать ответ
Ответ:
sofialolollollo
sofialolollollo
03.10.2020 11:29
Ну функция randomize() создаёт, перемешивает новые рандомные числа, а random() их предоставляет.
Разных вариаций написания много, я например сделал с массивом, можно в принципе и без него, но с ним лучше т.к. числа хранятся в массиве и их можно выводить в будущем, если это слишком сложно для тебя, то я могу написать программу без использования массива.

Var i,b:integer;
    A:array[1..20] of integer;
Begin
  Randomize();
  for i:=1 to 20 do
  A[i]:=Random(0,50);
Write('Из чисел: ');
   for i:=1 to 20 do
    begin
    if i=20 then
      Writeln(A[i])
       else Write(A[i],', ')
    end;
Write('Кол-во четных равняется: ');
  for i:=1 to 20 do
             if (A[i] mod 2 = 0) then b:=b+1;
Writeln(b)
End.

Вот выводы программы, которые у меня получились.

Первый раз:
Из чисел: 42, 1, 46, 24, 36, 9, 22, 16, 7, 41, 49, 46, 27, 29, 50, 44, 44, 10, 48, 36
Кол-во четных равняется: 13

Второй раз:
Из чисел: 5, 16, 16, 27, 1, 48, 46, 45, 46, 13, 21, 18, 24, 45, 14, 13, 33, 14, 21, 30
Кол-во четных равняется: 10

Третий раз:
Из чисел: 15, 2, 24, 42, 49, 43, 5, 48, 8, 1, 45, 9, 20, 24, 35, 19, 11, 15, 26, 33
Кол-во четных равняется: 8

Файл с кодом прикреплю во вложения, спрашивай если не понятна какая-то функция, объясню, дабы ты не стоял в ступоре перед учительницей...
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота