В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
selemenevakrist
selemenevakrist
21.09.2022 00:38 •  Информатика

решить задачу на C++ Дан целочисленный массив из 30 элементов. Элементы массива могут принимать произвольные
целые значения. Напишите программу, которая находит и выводит номера двух элементов массива, сумма которых минимальна.

Показать ответ
Ответ:
TToMoLLIHuK1
TToMoLLIHuK1
12.11.2020 05:08

Объяснение:

// Example program

#include <iostream>

#include <string>

int main()

{

   int k[30];

   for(int i = 0; i < 30; i ++) //заполняем случайными числами

       k[i] = rand();

   int min_sum = 999999999;

   int num1, num2;

   for(int i = 0; i < (30 - 1); i ++) //цикл поиска, i меняется от начала

                                      //до предпоследнего элемента, чтобы не выйти

                                      //за пределы при обращении к i + 1 элементу

   {

       int sum = k[i] + k[i+1];//очередная сумма

       if(sum < min_sum) //сравниваем ее с текущим минимумом

       {//если она меньше, то

           min_sum = sum;//обновляем текущую сумму

           num1 = i; num2 = i + 1;//обновляем номер

       }

   }

   //на выходе из цикла в min_sum и num1 и num2 имеем самые минимальные номера

   std::cout << "min_sum = " << min_sum << " nomer1 = " << num1 <<" nomer2 = " << num2;

}


решить задачу на C++ Дан целочисленный массив из 30 элементов. Элементы массива могут принимать прои
решить задачу на C++ Дан целочисленный массив из 30 элементов. Элементы массива могут принимать прои
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота