В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История

решить задание по информатике : 1. Составить программу нахождение площадии периметра прямоугольника.

2. В пяти тестовых о мальчик получил оценки. Составьте алгоритм и программу, которая определит среднее значение оценок, полученных мальчиком в пяти о

Показать ответ
Ответ:
viktoriakovalch
viktoriakovalch
17.10.2022 04:24

Графические редакторы - пакеты, предназначенные для обработки графической информации. Они делятся на ППП обработки растровой графики и изображений и векторной графики. Растровые графические редакторы предназначены для работы с фотографиями и включают в себя набор средств по кодированию фотоизображения в цифровую форму.

С растровых графических редакторов можно обрабатывать фотографии и рисунки, поскольку растровые изображения обеспечивают высокую точность передачи градаций цветов и полутонов. Структура растровых изображений кардинально отличается от векторных. Растровые изображения состоят из отдельных точек - пикселей. Такие изображения обеспечивают максимальную реалистичность, поскольку в цифровую форму переводится каждый мельчайший фрагмент оригинала. Такие изображения сохраняются в файлах гораздо большего объёма, чем векторные, поскольку в них запоминается информация о каждом пикселе изображения. Таким образом, качество растровых изображений зависит от их размера (числа пикселей по горизонтали и вертикали) и количества цветов. Как следствие того, что они состоят из пикселей фиксированного размера, свободное масштабирование без потери качества к ним не применимо. Эта особенность, а также сама структура растровых изображений несколько затрудняет их редактирование и обработку.

Векторные изображения являются оптимальным средством для хранения высокоточных графических объектов (чертежи, схемы и т. д.), для которых имеет значение наличие четких и ясных контуров. Все компоненты векторного изображения описываются математически, а значит - абсолютно точно. Векторные изображения, как правило, строятся вручную, однако в некоторых случаях они могут быть также получены из растровых с программ трассировки. Векторные изображения не в состоянии обеспечить близкую к оригиналу реалистичность, но достоинством векторной графики является то, что файлы, хранящие векторные графические изображения, имеют сравнительно небольшой объем. Важно также, что векторные графические изображения могут быть увеличены или уменьшены без потери качества.

Панели инструментов графических редакторов. Графические редакторы имеют набор инструментов для создания или рисования простейших графических объектов: прямой линии, кривой, прямоугольника, эллипса, многоугольника и т. д. После выбора объекта на панели инструментов его можно нарисовать в любом месте окна редактора. Выделяющие инструменты. В графических редакторах над элементами изображения возможны различные операции: копирование, перемещение, удаление, поворот, изменение размеров и т. д. Чтобы выполнить какую-либо операцию над объектом, его сначала необходимо выделить.

Для выделения объектов в растровом графическом редакторе обычно имеются два инструмента: выделение прямоугольной области и выделение произвольной области. Процедура выделения аналогична процедуре рисования.

Выделение объектов в векторном редакторе осуществляется с инструмента выделение объекта (на панели инструментов изображается стрелкой). Для выделения объекта достаточно выбрать инструмент выделения и щелкнуть по любому объекту на рисунке. Инструменты редактирования рисунка позволяют вносить в рисунок изменения: стирать его части, изменять цвета и т. д. Для стирания изображения в растровых графических редакторах используется инструмент Ластик, который убирает фрагменты изображения (пиксели), при этом размер Ластика можно менять. В векторных редакторах редактирование изображения возможно только путем удаления объектов, входящих в изображение, целиком. Для этого сначала необходимо выделить объект, а затем выполнить операцию Вырезать.

Операцию изменения цвета можно осуществить с меню Палитра, содержащего набор цветов, используемых при создании или рисовании объектов.

Текстовые инструменты позволяют добавлять в рисунок текст и форматировать его. В векторных графических редакторах легко изменять реальные размеры объекта с мыши.

В растровых редакторах инструментом Надпись (буква А на панели инструментов) создаются текстовые области на рисунках. Установив курсор в любом месте текстовой области, можно ввести текст. Форматирование текста производится с панели Атрибуты текста. В векторных редакторах тоже можно создавать текстовые области для ввода и форматирования текста. Кроме того, надписи к рисункам вводятся посредством так называемых выносок различных форм.

Масштабирующие инструменты в растровых графических редакторах дают возможность увеличивать или уменьшать масштаб представления объекта на экране, не влияя при этом на его реальные размеры. Обычно такой инструмент называется Лупа.

Объяснение:

0,0(0 оценок)
Ответ:
School30zh
School30zh
07.06.2022 00:02

C++

Объяснение:

#include <iostream>

using namespace std;

#include <string>

//На вход программы поступает неизвестное количество целых чисел, ввод заканчивается нулём.Найти среднее арифметическое всех двузначных чисел которые делятся на 7. С++

int main()

{

int number;

int count = 0;

float summ = 0;

int otvet;

cin >> number;

while (number != 0) {

 cin >> number;

 if ((number >= 10 && number <= 99) && (number % 7 == 0)) {

  summ += number;

  count++;

 }

 if (number == 0) {

  otvet = summ / count;

  cout << "Otvet: " << otvet << endl;

  break;

 }

}

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота