В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
IgorPoberezhny
IgorPoberezhny
23.02.2023 03:06 •  Информатика

Решите , используя язык программирования паскаль: напишите программу вычисления стоимости покупки, состоящей из нескольких карандашей, линеек и тетрадей. их количество и цену задать вводом. ответ вывести в виде: сумма к оплате: … руб … коп.

Показать ответ
Ответ:
bolshakovatanyoxd2gr
bolshakovatanyoxd2gr
03.10.2020 02:35
Var
k,kc,ks, r,rc,rs, l,lc,ls: Integer;
Summa: Integer;
begin
WriteLn('Введите цену карандаша'); ReadLn(kc);
WriteLn('Введите цену ручки'); ReadLn(rc);
WriteLn('Введите цену линейки'); ReadLn(lc);

WriteLn('Введите кол-во карандашей'); ReadLn(k);
WriteLn('Введите кол-во ручек'); ReadLn(r);
WriteLn('Введите кол-во линеек'); ReadLn(l);

ks:= k * kc; // цена карандашей
rs:= r * rc; // цена ручек
ls:= l * lc; // цена линеек
Summa:= ks + rs +ls; // общая цена всех 3-х
WriteLn('Сумма = ', Summa;
ReadLn;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота