В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
nasowmza
nasowmza
29.11.2022 05:00 •  Информатика

Решите ( желательно питон или просто разъяснить алгоритм)

играют двое. задаётся какая-то дата 2020 года. каждый игрок на своём ходе называет более позднюю дату, увеличивая на 1 или 2 либо день в месяце, либо месяц, но не то и другое сразу. при этом сочетание дня и месяца должно оставаться датой. игрок, назвавший 31 декабря, проигрывает. оба играют наилучшим образом. исходя из заданной даты вывести, кто выиграет.

входные данные
в первой строке находятся числа, обозначающие день и месяц.

выходные данные
вывести 1, если выигрывает первый (начинающий) игрок, или 2 - в противном случае.

экзампл :
входные данные
30 12
выходные данные
2

Показать ответ
Ответ:
FinSpb
FinSpb
26.04.2022 02:41

import java.util.Scanner;

public class Authenticator {

public static void main(String[] args) {

 String login;

 String password;

 Scanner scan = new Scanner(System.in);

 

 System.out.println("login:");

 login = scan.next();

 System.out.println("password:");

 password = scan.next();

 

 if(login.equals("user") && password.equals("qwerty")){

  System.out.println("Authentication completed");

 }else{

  System.out.println("Invalid login or password");

 }

 

 scan.close();

 

}

}

Объяснение:

Краткий алгоритм этой программы:Импортируем класс Scanner(для ввода текста);В методе main создаем две переменные типа String и одну типа Scanner;Вводим значения при а;Если логин и пароль верны,то выводим Authentication completed. Иначе выводим Invalid login or password;Закрываем Scanner;
0,0(0 оценок)
Ответ:
Emmaasakura
Emmaasakura
25.12.2021 02:14
Const l = 5;
var
a: array[1..l] of integer;
d: array[1..l] of real;
i, otr, k, m: integer;
begin
otr:=0; k:=0; m:=0;
//считаем массив а
for i:=1 to l do
  begin
    readln(a[i]);
    //если ввели положительное число,увеличим перем. otr на 1
    if a[i] < 0 then
      inc(otr);
    //если ввели отрицательное число,увеличим перем. k на 1
    //и к переменной m прибавим элемент
    if a[i] > 0 then
      begin
        inc(k);
        inc(m, a[i]);
      end;
  end;
//заполним массив d
for i:=1 to l do
  //если индекс четный, присвоим элементу otr
  //иначе присвоим среднее арифметическое
  if i mod 2 = 0 then
    d[i] := otr
  else
    d[i] := m/k;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота