В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
YTCoolboy55
YTCoolboy55
11.05.2022 13:55 •  Информатика

С++ ан массив из n элементов. Необходимо найти количество элементов массива, значения которых неотрицательны и меньше заданного числа A.

Формат входных данных
С клавиатуры вводится натуральное число n (n≤100). На следующей строке через пробел вводятся n элементов массива. Все числа по модулю не превосходят 100. В последней строке вводится единственное число A (0≤A≤100).

Формат выходных данных
В качестве ответа выведите единственное число — количество элементов, удовлетворяющих условию.
входные данные
5
1 2 3 4 5
3
выходные данные
2

Показать ответ
Ответ:
Jamalove
Jamalove
18.05.2021 19:50

int main()

{

size_t n;

std::cin >> n;

std::ostringstream out;

for (size_t i = 0; i < n; ++i)

{

static short a;

std::cin >> a;

if (a <= 0) out << (i + 1) << ' ';

}

std::cout<<out.str();

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота