В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
66546654
66546654
22.01.2021 13:20 •  Информатика

С++
написать программу
с клавиатуры вводятся n чисел. составьте программу, которая определяет количество отрицательных, кол-во положительных и количество нулей среди введённых чисел. значение n вводится с клавиатуры

Показать ответ
Ответ:
Beario
Beario
10.10.2020 17:19

#include <iostream>

using namespace std;

int main()

{

int n,x,k_otr=0,k_pol=0,k_nul=0;

cin>>n;

for(int i=1;i<=n;i++)

{

cin>>x;

if(x>0)

 k_pol++;

else if(x<0)

 k_otr++;

else

 k_nul++;

}

cout<<"k_pol="<<k_pol<<"; k_otr="<<k_otr<<"; k_nul="<<k_nul;

return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота