В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История

С. напишите программу подсчёта суммы всех отрицательных элементов заданного целочисленного массива размером 30 элементов. если отрицательных элементов нет, то сообщить об этом) p.s. в паскале

Показать ответ
Ответ:
twentytw
twentytw
15.07.2020 17:11
Var
  n, i, s, k:integer;
  a:array [1..30] of integer;
begin
  writeln('Vvedite massiv');
  for i:=1 to 30 do
  readln(a[i]);
  writeln('Massiv');
  for i:=1 to 30 do
  write(a[i],' ');
  writeln();
  k:=0; s:=0;
  for i:=1 to 30 do
  if a[i]<0 then
  begin
  s:=a[i]+s;
  k:=1;
  end;
  if k=1 then
  writeln('Summa otricatelnih elementov: ',s)
  else
  writeln('Otricatelnih elementov net');
  readln();   
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота