В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
twistella
twistella
06.04.2023 22:59 •  Информатика

с решением Решение на языке Паскаль

На обработку поступает натуральное число, не превышающее 109. Нужно написать программу, которая выводит на экран произведение цифр числа, которые делятся на 2 и на 4. Если в числе нет таких цифр, требуется на экран вывести «NO».

Показать ответ
Ответ:
даниил921
даниил921
24.08.2020 11:57

var N,digit,maxDigit: longint;

begin

readln(N);

maxDigit := N mod 10;

while N > 0 do

begin

digit := N mod 10;

if digit mod 3 = 0 then

if digit > maxDigit then

maxDigit := digit;

N := N div 10;

end;

if maxDigit = 0 then

writeln('NO')

else

writeln(maxDigit)

end.

Объяснение:

вроде так

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота