Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
crosser001
20.01.2022 03:54 •
Информатика
С! составить программу в паскале 1. найти сумму нечетных чисел в промежутке от 20 до n
Показать ответ
Ответ:
Василиса73
08.10.2020 17:24
Берем первое нечетное в этом диапазоне (21) и прибавляем к нему все числа через одно (т.е. тоже все нечетные), пока не выйдем за пределы n.
PascalABC.NET 3.3.5, сборка 1662 от 29.04.2018
Внимание! Если программа не работает, обновите версию!
begin
Writeln('S=',Range(21,ReadInteger('n='),2).Sum)
end.
Пример
n= 250
S=15525
0,0
(0 оценок)
Популярные вопросы: Информатика
lilitabraamyan
13.01.2021 19:08
Program calk; uses crt; var a,b,c,d,x1,x2 : real; begin textcolor(red); gotoxy(10,5); write( вас калькулятор решать квадратные уравнения ); gotoxy(10,6); write( введите...
Kamila281637
12.10.2022 06:20
Задано данные о n = 10 учащихся класса: фамилия, имя, отчество, датарождения (год, номер месяца и число). составить программу, которая определяет, есть ли вклассе ученики,...
skrlp1234
11.06.2022 17:45
X : real; writeln(x:0:0); writeln(x:0:1); x:0:0=6 x:0:1=6.3 Пример ввода:6.3...
Кетшити
02.01.2023 10:12
Python. Дано натуральное число. напишите программу, которая находит сумму его цифр. ...
Sasga59832
02.04.2021 14:15
напишите программу вывода на экран всех дней января прогнозный ращмер осадков в которые не превысит значение 9.размер осадков определить случайным образом...
ilia200575
01.01.2023 15:43
Напишите программу,которая считает,Сколько целых чисел начиная с 0 нудно сложить чтобы их сумма не превышаоа число введенное с клавиатуры...
Троцкий1
23.11.2020 19:19
Самостоятельная работавариант — 12оформить по плану решения , построить блок-схему и написатьпрограмму вычисления значения выражения, используя операторприсваивания: укажите...
Vasilyeva5
24.08.2021 04:04
Вдается количество нулей в конце результата функции factorial(n). требуется вычислить минимальное число n. определение factorial(a) = a! = (a-1) ! * a = 1 * 2 * 3 * * (a-1)...
kustsireni
26.03.2022 02:00
Срефератом, надо, 25 от web 1.0 к web 3.0 2 курс...
sofiabts
30.11.2021 15:14
Найти количество и сумму всех нечетных чисел на интервале от с до д...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
PascalABC.NET 3.3.5, сборка 1662 от 29.04.2018
Внимание! Если программа не работает, обновите версию!
begin
Writeln('S=',Range(21,ReadInteger('n='),2).Sum)
end.
Пример
n= 250
S=15525