В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
baekksas
baekksas
03.11.2021 13:18 •  Информатика

с задачей по паскаль.
Даны текстовые файлы c и d, в которых целые числа записаны через пробел в нескольких строках. Записать в текстовый файл g числа, присутст-вующие в обоих файлах.

Показать ответ
Ответ:
kaukov03
kaukov03
07.03.2020 04:44
Запрашивается цены товаров и их количество в начале рабочего дня.
Запрашивается количество проданного товара.
Выводится ответ.
Возможно, надо было запросить не кол-во проданного товара, а кол-во оставшегося товара, но я составил программу по условию. (если нужна будет другая, то отредактирую)

program tovar;
var t1,t2,p1,p2:integer;
    c1,c2,s:real;
Begin
WriteLn('Сколько товаров первого вида было в начале рабочего дня?');
ReadLn(t1);
WriteLn('Цена товаров первого вида?');
ReadLn(c1);
WriteLn('Сколько товаров второго вида было в начале рабочего дня?');
ReadLn(t2);
WriteLn('Цена товаров второго вида?');
ReadLn(c2);
WriteLn('сколько товаров перового вида было продано за день?');
ReadLn(p1);
WriteLn('сколько товаров второго вида было продано за день?');
ReadLn(p2);
s:=p1*c1+p2*c2;
WriteLn('Выручка за день ' ,s);
end.

/// Возник вопрос. Зачем спрашивать, сколько товаров было в начале рабочего дня, если эти данные не используются, вот я и решил составить программу, которая, возможно, требовалась

program tovar;
var t1,t2,p1,p2:integer;
    c1,c2,s:real;
Begin
WriteLn('Сколько товаров первого вида было в начале рабочего дня?');
ReadLn(t1);
WriteLn('Цена товаров первого вида?');
ReadLn(c1);
WriteLn('Сколько товаров второго вида было в начале рабочего дня?');
ReadLn(t2);
WriteLn('Цена товаров второго вида?');
ReadLn(c2);
WriteLn('сколько товаров перового вида осталось?');
ReadLn(p1);
WriteLn('сколько товаров второго вида осталось?');
ReadLn(p2);
s:=(t1-p1)*c1+(t2-p2)*c2;
if (t1-p1<0) or (t2-p2<0) then WriteLn('Внимание! Кол-во оставшихся товаров, больше чем кол-во товаров в начале рабочего дня. Проверьте правильность данных.');
WriteLn('Выручка за день ' ,s);
end.
0,0(0 оценок)
Ответ:
Nikitaprodakshen
Nikitaprodakshen
21.01.2023 00:51
Программа приложена файлом для Visual Basic for Applications

Ниже текст этой программы продублирован

Sub trans_sequence(ByVal M)'заполнение массива и создание преобразованной последовательности чисел  N = M  Dim mas()  ReDim mas(M)  Sg = ""  Sf = ""  Randomize  For i = 1 To M    mas(i) = Round((Rnd(100) - 0.5) * 100)    Sg = Sg + Str(mas(i))    If (mas(i) < 0) Then mas(i) = mas(i) * mas(i)    Sf = Sf + Str(mas(i))    If i <> M Then           Sg = Sg + ","       Sf = Sf + ","    End If  Next i        MsgBox "последовательность чисел " + Sg + Chr(10) + "преобразованная последовательность " + SfEnd Sub

Sub test()  trans_sequence (25)End Sub
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота