В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
sobennikovaox
sobennikovaox
03.06.2021 06:21 •  Информатика

сегодня надо сдать на проверку
в среде pascal abs
Задание 1
Составить программу вычисления значения функции
для любого значения a, введенного с клавиатуры.
Задание 2
Задан квадрат с длиной стороны а. Найти его площадь и длину диагонали.
Задание 3
Написать программу, определяющую, сколько времени затратит школьник на дорогу от школы до дома, если известна длина этого расстояния s и средняя скорость движения v. Значение скорости и расстояние движения задаются с клавиатуры.

Показать ответ
Ответ:
olgavasileva67
olgavasileva67
24.06.2022 09:21

Работа с римскими цифрами:

– Римские цифры: I = 1, V = 5, X = 10, L = 50, C = 100, D = 500, M = 1000

– Если цифра меньшего номинала стоит перед цифрой большего номинала, то её значение вычитается, при этом V не вычитается.

– Не должно быть больше трёх одинаковых цифр подряд

– Вычитаться не может больше одной одинаковой цифры


1. XI = 10 + 1 = 11

IX = -1 + 10 = 9

LX = 50 + 10 = 60

CLX = 100 + 50 + 10 = 160

MDCXLVIII = 1000 + 500 + 100 - 10 + 50 + 5 + 1 + 1 + 1 = 1648


2. 13 = 10 + 1 + 1 + 1 = XIII

99 = -10 + 100 - 1 + 10 = XCI (в упрощенной системе записи допустимо -1 + 100 = IC)

666 = 500 + 100 + 50 + 10 + 5 + 1 = DCLXVI

1692 = 1000 + 500 + 100 - 10 + 100 + 1 + 1 = MDCXCII


_______________________________________________


Если в десятичной системе счисления числа записываются по степеням 10 (например, 123 = 1 * 100 + 2 * 10 + 3 * 1), то в системе с основанием b всё записывается по степеням числа b (123_b=1\cdot b^2+2\cdot b+3\cdot 1). При этом цифры в системе счисления с основанием b принимают значение от 0 до b - 1; если цифр не хватает, то в ход идут буквы: A = 10, B = 11, C = 12, ...


3. Двоичная СС:

\begin{array}{ccc}\times&0_2=0_{10}&1_2=1_{10}\\0_2=0_{10}&0_2=0_{10}&0_2=0_{10}\\1_2=1_{10}&0_2=0_{10}&1_2=1_{10}\end{array}


Троичная СС:

\begin{array}{cccc}\times&0&1&2\\0&0&0&0\\1&0&1&2\\2&0&2&11_3=3+1=4\end{array}


4. Обозначаем основание системы счисления за b, расписываем каждое число и получаем уравнения:

1) 5 + 4 = b + 1

b = 8

2) 4 + b + 1 = 2b

b = 5

3) b + 1 + b = b^2 + 1

b = 0 или 2 – основание сс не может быть равно 0

b = 2

4) b + 5 = 15

b = 10 – не подходит, в десятичной сс не может быть цифры F

ответ: 1) в восьмеричной, 2) в пятеричной, 3) в двоичной, 4) такого не бывает ни в какой системе счисления

0,0(0 оценок)
Ответ:
tbbkc
tbbkc
24.06.2022 09:21
// ConsoleApplication60.cpp: определяет точку входа для консольного приложения.//
#include "stdafx.h"#include<conio.h>#include"iostream"#include "stdio.h"#include "time.h"
using namespace std;
int main(){ int x, y,c; setlocale(LC_ALL, "RUS"); srand((unsigned)time(NULL)); x = rand() % 8 + 2; y = rand() % 8 + 2; cout << "Сколько будет  " << x << "*" << y << "?" << "\n"; cout << "Введите ответ и нажмите Enter  "; cin >> c; if (x*y == c) { cout << "Правильно\n";  } else { cout << "Вы ошиблись   " << x << "*" << y << "=" << c;  } return 0;}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота