В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
kseniasergeeva10
kseniasergeeva10
21.11.2021 05:25 •  Информатика

Синформатикой. №5. написать программу на языке паскаль: ввести два натуральных числа a и b, вывести сумму всех целых чисел от а до b, n – количество целых чисел. №6. написать программу на языке паскаль: ввести два натуральных числа a и b, вывести квадраты и кубы нечетных чисел от a до b (включая a и b). №7. дан массив чисел. найти значение максимального элемента. если таких элементов несколько, то определить, сколько их.

Показать ответ
Ответ:
ermoloffalexan
ermoloffalexan
31.07.2020 17:07

Вариант для С++:

#include <iostream>

#include <algorithm>

#include <array>

#include <iterator>


int main()

{

   std::array<size_t, 12> arr{1, 2, 5, 6, 8, 5, 7, 4, 7, 8, 5, 8};

   //std::generate(arr.begin(), arr.end(), std::rand);


   std::copy(arr.begin(), arr.end(),

       std::ostream_iterator<size_t>(std::cout, " "));


   std::cout << std::endl << "Количество максимальных элементов = " <<

       std::count(arr.begin(), arr.end(), *std::max_element(arr.begin(), arr.end())) << std::endl;

}


Опишите на языке или одном из языков программирования алгоритм подсчета числа элементов, равных макс
0,0(0 оценок)
Ответ:
alexandrafortun
alexandrafortun
31.07.2020 17:07

Алгоритм слова "БАОБАБ"

Вс Процедура Б Нач (Записывай в столбик) Шаг-Поворот-Поворот-Поворот-Шаг-Шаг-Поворот-Поворот-Шаг-Поворот-Шаг-Поворот-Шаг-Поворот-Поворот-Поворот-Шаг-Поворот-Поворот-Поворот-Шаг-Прыжок Кон    Процедура АНач шаг-поворот-поворот-поворот-шаг-шаг-поворот-поворот-поворот-шаг-поворот-шаг-поворот-шаг-поворот-поворот-шаг-шаг-поворот-поворот-поворот Кон   Процедура ОНач шаг-поворот-поворот-поворот-шаг-шаг-поворот-поворот-поворот-шаг-поворот-поворот-поворот-шаг-шаг-поворот-поворот-поворот-шаг-прыжок

Алг Баобаб

Нач (Столбиком тоже) сделай Б - сделай А - сделай О - сделай Б - сделай А - сделай Б Кон

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота