В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
buzalola123
buzalola123
23.01.2020 06:40 •  Информатика

Склавиатуры одной строкой вводят имя и фамилию. составьте программу, которая определяет, есть ли во введенной строке заданный символ

Показать ответ
Ответ:
Gvgvv
Gvgvv
06.06.2020 21:45

var
slovo,simval:string;
i,k:integer;
begin
k:=0;
 write('Введите имя и фамилию ');
readln(slovo);
write('Введите символ ');
readln(simval);
for i:=1 to length(slovo) do
begin
if slovo[i]=simval then k:=k+1;
if slovo[i]=simval then writeln(i,' ');
end;
if k>=1 then
 writeln('Да, встречается ',k,' раз, на позиции ',i)else writeln('Нет');
end.

 

 

Я немножко перевыполнил) От показывает есть симаол или нет, если есть то сколько раз он входит и на какой позиции... 

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота