Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
AlinaAlina110624
30.09.2020 11:13 •
Информатика
Склавиатуры вводится n чисел. написать программу, которая определяет количество отрицательных, количество положительных и количество нулей среди введённых чисел. значение n также вводится с клавиатуры. язык с++
Показать ответ
Ответ:
DanyaHD
06.10.2020 11:31
#include<iostream>
using namespace std;
int main()
{
int n, A, P = 0, O = 0, N = 0;
cout << "n = ", cin >> n;
for (int i = 0; i < n; i++)
{
cin >> A;
if (A > 0) P++;
else if (A < 0) O++;
else N++;
}
cout << "( < 0): " << O;
cout << "\n( = 0): " << N;
cout << "\n( > 0): " << P;
return 0;
}
0,0
(0 оценок)
Популярные вопросы: Информатика
ascor3337
05.10.2020 04:03
Ребята, кто из домашней школы в 10 классе, напишите мне в инст @alenka_borevich , есть во...
shtoshpulodov
22.03.2022 23:36
Даны 2 числа. если они положительные - умножить их на 3, иначе - возвести в квадрат. в pascal...
muslima2003
22.04.2023 09:14
Найти число по двоичному коду и решение число 101101110; 10100100 !...
Chicken10
06.03.2020 13:56
Какие двоичные числа соответствуют следующим десятичным числам: 128,256,512,1024...
Лях1
12.11.2022 01:24
Написать план до твору Третій сніг...
ВопросикиОтШколоты
25.05.2022 07:21
с заданием. Упражнение 4...
angelina453
21.12.2021 03:37
Місто Одеса було застосовано в 1794 році обчисліть у якому році святкуватимуть її 250-річчя...
БезликийNoName
30.08.2021 12:48
6 Complete the text in Exercise 5 with the present continuous form of the verbs in brackets...
Приветипока
06.03.2020 22:17
писать все действия.941 одним действием...
rsdfa
05.05.2021 04:29
1. Определите тему стихотворения. Что же слышит Джамбул теперь?К вам в Стальную ломится дверь,Словно вечность проголодав,обезумевший от потерьМногоглавый жадный удав...Сдохнет...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
using namespace std;
int main()
{
int n, A, P = 0, O = 0, N = 0;
cout << "n = ", cin >> n;
for (int i = 0; i < n; i++)
{
cin >> A;
if (A > 0) P++;
else if (A < 0) O++;
else N++;
}
cout << "( < 0): " << O;
cout << "\n( = 0): " << N;
cout << "\n( > 0): " << P;
return 0;
}