Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
ghromovrostisl22
28.07.2020 03:32 •
Информатика
Смассива a(10) сформировать массив в(10), отличный от исходного тем, что числа, кратные 5 удвоены
Показать ответ
Ответ:
roman286
07.10.2020 00:39
#include <cstdio>
template< typename int_dt >
int_dt *
transform(int_dt *arr, size_t n)
{
int_dt *new_arr = new int_dt[n];
for (int i = 0; i < n; i++) {
new_arr[i] = arr[i] % 5 ? arr[i] : 2 * arr[i];
}
return new_arr;
}
int
main(void)
{
enum
{
ARR_SIZE = 10
};
int a[] = {1, 2, 3, 4, 5, 6, 7, 8, 9, 10};
int *b = transform(a, ARR_SIZE);
for (int i = 0; i < ARR_SIZE; i++) {
printf("%d ", b[i]);
}
delete[] b;
return 0;
}
0,0
(0 оценок)
Популярные вопросы: Информатика
380973599293
06.02.2021 03:14
Дано натуральное число, найти число десятков в нем! требуется с величинами, преобразовать в цифру и вычислить(val str)...
zadojnov09
09.09.2021 00:59
Написать программу , которая должна производиться действия над векторами и матрицами, оформленными в виде функций. должна быть генерация векторов и матриц произвольного размератакже...
Anutka15Love
17.02.2021 00:58
На деякій гральній дошці, яка має форму прямокутної таблиці з 5 стовпців і 5 рядків, випадково розміщуються білі та чорні фігури. У вибраному середовищі програмування створіть...
Zhekka123
27.10.2021 23:49
var a,b,c,k:real; begin; write( Введите первое число прогрессии: ); readln(a); write( Введите разность прогрессии: ); readln(b); write( Введите число членов прогрессии: ); readln(c);...
ворона1111
01.11.2020 20:41
сделать програму на пайтоне. Составить программу, которая спросит у пользователя его фамилия и имя и вернет их записаны в обратном порядке с соблюдением правил написания имен:...
КристинаСтерликова
13.12.2021 17:21
составить програму вычисления функции y= { 8x^2, x 0 1/3√14x, x≥0...
Лиза2005111111111
01.09.2021 05:38
Найдите сумму чисел от a до b pascal...
alexaaa2
16.01.2020 21:00
Выбери визуальные html-редакторы. coffeecup visual site designer htmldocedit web development studio notepad2 toweb...
JANAAAAAA
19.11.2020 10:30
Количество пикселей: 2211840. запиши правильный ответ, округли ответ до сотых. 2211840 пикселей = мегапикселей....
Maksikikl
09.09.2021 13:03
4. через сколько дней выздоровеет больной, если применению лекарства концентрация бактерий уменьшается ежедневно на 20% от предыдущего количества. первоначальная концентрация...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
template< typename int_dt >
int_dt *
transform(int_dt *arr, size_t n)
{
int_dt *new_arr = new int_dt[n];
for (int i = 0; i < n; i++) {
new_arr[i] = arr[i] % 5 ? arr[i] : 2 * arr[i];
}
return new_arr;
}
int
main(void)
{
enum
{
ARR_SIZE = 10
};
int a[] = {1, 2, 3, 4, 5, 6, 7, 8, 9, 10};
int *b = transform(a, ARR_SIZE);
for (int i = 0; i < ARR_SIZE; i++) {
printf("%d ", b[i]);
}
delete[] b;
return 0;
}