В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
tuiyty
tuiyty
17.12.2020 22:57 •  Информатика

Сортировка. метод выбора. напишите программу, которая сортирует массив и находит количество различных чисел в нем. пример: массив: 5 3 4 2 1 6 3 2 4 после сортировки: 1 2 2 3 3 4 4 5 6 различных чисел: 6 нужно . ,люди ,добрые

Показать ответ
Ответ:
kiert
kiert
03.08.2020 10:06
Begin
  var c, min, imin: integer;
  c := 0;
  var ar := readarrinteger('Массив:',readinteger());
  for var i := 1 to ar.Length do
  begin
    min := ar[c];
    imin := c;
    for var j := c to ar.Length - 1 do
    begin
      if(ar[j] < min) then
      begin
        min := ar[j];
        imin := j;
      end;
    end;
    swap(ar[c], ar[imin]);
    c := c + 1;
  end;
  write('После сортировки: ');
  ar.Println;
  write('Различных чисел: ',ar.Distinct.Count);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота