В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
мирби1
мирби1
18.01.2021 09:23 •  Информатика

Составить блок схему и написать программу, которая находит сумму нечетных и количество четных делителей натурального числа.(31954)

Показать ответ
Ответ:
KESALIVE
KESALIVE
01.10.2020 18:30
Var n,i,k,s:integer;
begin
read (n);
k:=0;
s:=0;
for i:=1 to n do
begin
if (n mod i = 0) then
begin
if (i mod 2 = 0)then
begin
k:=k+1;
end else
begin
s:=s+i;
end;
end;
end;
writeln ('Кол-во чётных - ',k);
writeln ('Сумма нечётных - ',s);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота