В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История

Составить блок-схему и написать программу на языке Паскаль выводящую на экран таблицу значений функции f(x) для х є [a;b]
(a,b - целые, a>b) с шагом -1​

Показать ответ
Ответ:
Evelynimmortal
Evelynimmortal
14.10.2020 20:25

f(x) = x2 -2

сам решал могут быть не большие погрешности

0,0(0 оценок)
Ответ:
kira1180
kira1180
14.10.2020 20:25

program z1;

var a,b,x: integer;

f:real;

begin

write ('a = ');

readln (a);

write ('b = ');

readln (b);

for x:=a to b do

begin  

if x>2 then f:=x*x-3

else if x<-2 then f:=x/3

else f:=abs(x-2);

writeln ('f(',x:2,') = ',f)

end

end.

Объяснение:

Смотри картинку

Это цикл для a < b c шагом 1.

Если цикл для a > b c шагом -1, то 9 строку (for x:=a to b do) заменяем на for x:=a downto b do.


Составить блок-схему и написать программу на языке Паскаль выводящую на экран таблицу значений функц
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота