В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
arystan307
arystan307
08.02.2022 14:41 •  Информатика

Составить программу
1 Ввести число. Сообщить, что больше логарифм или синус числа
2 Ввести 2 числа. Сообщить, что больше синус первого или второго
3 Ввести 2 числа, напечатать большее из них, поделив на 100
4 Ввести 3 числа. Сообщить, попадает ли первое между вторым и
третьим

Показать ответ
Ответ:
XxШКОЛЬНИКxX
XxШКОЛЬНИКxX
18.05.2020 00:14

ответ: 80.

s: = 2 * k + s = 2 * (-5) + 0 = -10s: = 2 * k + s = 2 * (-4) + (-10) = -18s: = 2 * k + s = 2 * (-3) + (-18) = -24s: = 2 * k + s = 2 * (-2) + (-24) = -28s: = 2 * k + s = 2 * (-1) + (-28) = -30s: = 2 * k + s = 2 * 0 + (-30) = -30s: = 2 * k + s = 2 * 1 + (-30) = -28s: = 2 * k + s = 2 * 2 + (-28) = -24s: = 2 * k + s = 2 * 3 + (-24) = -18s: = 2 * k + s = 2 * 4 + (-18) = -10s: = 2 * k + s = 2 * 5 + (-10) = 0s: = 2 * k + s = 2 * 6 + 0 = 12s: = 2 * k + s = 2 * 7 + 12 = 26s: = 2 * k + s = 2 * 8 + 26 = 42s: = 2 * k + s = 2 * 9 + 42 = 60s: = 2 * k + s = 2 * 10 + 60 = 80
0,0(0 оценок)
Ответ:
polinaa6
polinaa6
11.05.2021 01:14

Смотри объяснение

Объяснение:

Я написал на Паскале, но объясню сам принцип работы, если вдруг ты пишешь на другом языке.

Описываем несколько целочисленных переменных. Три - k, l, m - нам уже даны по условию, создадим еще одну (s) для количества рыб, что достанется каждому, и a для остатка.

Вводим с клавиатуры три наших переменных.  Для того, чтобы найти, сколько рыб получит каждый, нам нужно сложить всё в одну кучу и поделить её на три равных части. Поэтому сложим их все, запишем общую сумму в переменную s.

Для того, чтобы найти, сколько рыб останется после раздела добычи, в Паскале предусмотрена функция mod - остаток от деления. Соответственно, присваиваем переменной а значение остатка переменной s от деления на 3.

При функции div - деление нацело - разделим переменную s на три и присвоим ей это значение.

Выводим наш ответ: сначала переменную s, потом а.

Надеюсь

var

 s, k, l, m, a: integer;

begin

  readln(k);

  readln(l);

  readln(m);

  s:=k+l+m;

  a:=s mod 3;

  s:=s div 3;

  writeln(s);

  writeln(a);

  end.

UPD: Добавил решение на Python:

k=int(input())

l=int(input())

m=int(input())

s=k+l+m

print(s//3)

print(s%3)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота