В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Marsel200301
Marsel200301
04.09.2021 03:49 •  Информатика

Составить программу для нахождения количества и суммы всех чисел, оканчивающихся на 4 на промежутке от 1 до 100. в паскале. подробно , чтобы было понятно.

Показать ответ
Ответ:
Starboi
Starboi
08.10.2020 17:12
Program aaa;
var
   i,z,sum:integer;
begin
   sum:=0; //сумма чисел
   z:=0; //счётчик
   for i:=1 to 100 do
      if(i mod 10 = 4) then begin //проверка последней цифры, если 4,то прибавляем к счётчику единицу и к сумме число
         z:=z+1;
         sum:=sum+i;
      end;
   writeln(z,' ',sum); //Выводим ответ
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота