Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
Dead94
21.09.2021 16:01 •
Информатика
Составить программу для нахождения количества таких трехзначных чисел фибоначчи, которые делятся на сумму своих цифр нацело. программа - pascal abc
Показать ответ
Ответ:
Luna28u
03.10.2020 08:41
Var
a,b,k,s: integer;
begin
k := 0;
a := 1;
b := 1;
while b < 1000 do
begin
if b >= 100 then
begin
s := b div 100 + b div 10 mod 10 + b mod 10;
if b mod s = 0 then
k := k + 1
end;
b := a + b;
a := b - a;
end;
write(k)
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
kasper212
30.03.2021 16:38
1. Этапы создания трёхмерного объекта. 2. Возможные варианты использования моделирования нужно...
Millat23
18.08.2021 16:39
Назви сучасні САПР,які можна використовувати для конструювання одягу....
666666ник
01.06.2023 02:18
Домашнее задание выполнить домашнее задание самостоятельно Составь рассказ по картинке набери его в текстовом редакторе Как ты думаешь какие устройства миллионы космонавт...
karashina2
24.05.2021 14:38
Сос сегодня надо будьте ! паскаль работа сгенерировать случайное число из промежутка квадратная скобка150,200) и выделить его первую и последнию...
eviilevii123
13.09.2021 19:37
Записать в двоичной системе счисления результат следующего выражения: (1008+1016*102)/103=2...
Lounges
22.12.2020 02:21
ЫЭСВ» - это слово зашифровано шифром Цезаря, используя ключ из предыдущего задания, раскодируй его, это тебе пройти следующий этап посвящения в программисты....
0ananasik0
11.06.2022 10:15
Для чого в середовищі програмування Lazarus потрібно розміщувати полотно до іть будь ласка ів...
Vitoriofedorov
10.02.2021 21:44
Дано арифметическое выражение вида S = 2*X1 + 3*X2 / (X2 + 3*X1) / (X2 + 25*X1).Напишите программный код , который позволит посчитать количество операций произведения в...
kshevchenko631
11.05.2022 08:44
1) Выберите, что является высказыванием: а) Почему это является высказыванием? б) Посмотрите в тетрадь! в) Карлсон — летучая морская рыба. г) Какого цвета Солнце? 2)Выберите,...
nastjaivanova20
09.01.2020 22:15
Зробити додаток магазин . В магазині мають бути якісь товари, ціна яких зберігається в змінних(мінімум 4 товари). Логіка програми. Користувач вибирає товар у магазині,та...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
a,b,k,s: integer;
begin
k := 0;
a := 1;
b := 1;
while b < 1000 do
begin
if b >= 100 then
begin
s := b div 100 + b div 10 mod 10 + b mod 10;
if b mod s = 0 then
k := k + 1
end;
b := a + b;
a := b - a;
end;
write(k)
end.