В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Evgenevgenevgen
Evgenevgenevgen
21.01.2021 05:26 •  Информатика

Составить программу для паскальабс.нет. количество чисел не кратных пяти в указанном диапазоне

Показать ответ
Ответ:
Polina14041
Polina14041
22.07.2020 18:23
Program vasha_zadacha_1;
var a,b,c:integer ; 
begin 
c:=0; 
writeln('введите промежуток от'); 
readln(a); 
writeln('до'); 
readln(b); 
if a>b then  
for b:=b to a do begin 
if (b mod 5<>0) then c:=c+1;   
end; 
for a:=a to b do begin   
if (a mod 5<>0) then c:=c+1; 
 end; 
writeln('колличество чисел не кратных пяти в этом диапазоне ', c); 
end.
0,0(0 оценок)
Ответ:
astakastaj
astakastaj
22.07.2020 18:23
Var i, a, b, count, crat:integer;
begin
readln(a, b);
for i:=a to b do
begin
crat:=i mod 5;
if crat <> 0 then
begin
count:=count+1
end;
end;
writeln('Количество не кратных = ', count);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота