Составить программу для решения следующей : приближенно можно считать, что скорость охлаждения горячего чая, налитого в стакан, пропорциональна разности между его температурой и температурой воздуха. за 1 минуту температура чая снижается на 3 % от разности этих температур. вывести на экран температуру чая по истечении каждой минуты в течении 15 минут. начальная температура воздуха - 20 градусов, начальная температура чая - 100. протокол: через 0 мин. - 100 градусов через 1 мин. - 97,6 градусов через 2 мин. - 95,3 градусов через 3 мин. - 93,1 градусов …
var t,t1:real; i:integer;
begin
t:=100;
t1:=20;
for i:=0 to 15 do
begin
writeln('Через ',i,' мин. - ',t:4:1,' градусов');
t:=t-(t-t1)*0.03;
end;
end.
Результат:
Через 0 мин. - 100.0 градусов
Через 1 мин. - 97.6 градусов
Через 2 мин. - 95.3 градусов
...
Через 14 мин. - 72.2 градусов
Через 15 мин. - 70.7 градусов