В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
alicaraut
alicaraut
11.05.2022 14:33 •  Информатика

Составить программу к решению : "дано число n. найти сумму и количество его цифр.

Показать ответ
Ответ:
Polymesiz
Polymesiz
26.06.2020 11:26
Var a,b,k,c,d:integer;
begin
read(a); k:=0; c:=10;
while k<>0 do begin
b:=b + a mod c;  k:=a div c; inc(d);
end;
write(b,d);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота