В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Khedi1999
Khedi1999
13.04.2020 09:49 •  Информатика

Составить программу, которая формирует массив, содержащий 15 случайных целых чисел, принадлежащий промежутку [0; 8], и преобразует элементы массива по следующему правилу: к чётному числу прибавляет 1, а нечётное умножает на 2.

Показать ответ
Ответ:
mmmaaakkkaaarrr
mmmaaakkkaaarrr
25.05.2020 11:46

var
  i: integer;
  a: array [1..15] of integer;

 

begin
  write('Исходный массив: ');
  for i:= 1 to 15 do //Формируем и распечатываем массив
  begin
    a[i]:= random(8); 
    write(a[i],' ');
  end;
  writeln; //Перевод на новую строку
  write('Преобразованный массив: ');
  for i:= 1 to 15 do
  begin
    if a[i] mod 2 = 0 then a[i]:= a[i] + 1 {Если элемент массива с индексом i четный, то прибавляем к нему 1, иначе умножаем на 2}
    else a[i]:= a[i] * 2;
    write(a[i], ' ');
  end;
  writeln; {Перевод на новую строку, чтобы при повторном запуске программы сформированный массив печатался на новой строке}
end.

Отметь решение, как лучшее

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота