В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
polosa48rus
polosa48rus
15.11.2020 04:01 •  Информатика

Составить программу, которая каждое введенное положительное число увеличивает в два раза, а отрицательное возводит в квадрат.

Показать ответ
Ответ:
max697
max697
01.10.2020 02:04

Pascal ABC

 

var a : integer;
begin
readln(a);
If a >= 0 then a := 2*a;
If a < 0 then a := a*a;
writeln(a)
end.

0,0(0 оценок)
Ответ:
Боня301205
Боня301205
01.10.2020 02:04

program z1;

uses crt;

var x,y:integer;

begin

clrscr;

writeln('введи число');

readln(x);

if x>=0 then x:=x*2 

else

if x<0 then sqr(x);

writeln(x);

readln;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота