Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
danilfkr
19.08.2021 05:36 •
Информатика
Составить программу ,которая находит наименьшее натуральное n, при котором 2n> = 20 (2 в степени n ), и результат наименьшеечисло n - выводит на экран
Показать ответ
Ответ:
семон1
16.09.2020 19:51
Var n,a:integer;
begin
n:=1;
a:=2;
repeat
for i:=1 to n do
a:=a*2;
n:=n+1;
until a>=20;
writeln(n)
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
dashani7562
01.01.2023 02:04
Строка Туе–Морса — бесконечная последовательность из нулей и единиц, которая получается следующим образом. В начале последовательности записана цифра 0. Затем повторяются следующие...
demoooon24
23.02.2022 21:39
На военном предприятие на компьютерах храниться очень важная информация (документы, программы и т.д.). Поэтому постоянно делается резервное копирование данных. Напишите две...
awdrg12345
23.02.2022 21:39
Задача 6: Наборы пирожных На складе кондитерской фабрики хранятся пирожные двух видов — круассаны и эклеры. Круассанов A штук, а эклеров — B штук. Есть неограниченный запас...
Folknesss14
30.07.2021 01:51
Запиши развёрнутую запись числа 0,934 для дробной части числа....
moxic37280
17.02.2022 02:54
8.3 Цифры 1 и 2, хранящиеся в “клетках” памяти компьютера, называются значениями битов А) верно Б)не верно...
katuschaglebtsc
21.05.2021 16:09
C++ Дан текст, представляющий собой десятичную запись целого числа. Вычислить сумму цифр этого числа....
ЛизаЕУ
12.02.2022 07:27
8.2 Значение 1-это включено А) верно Б) не верно...
theaziimut
30.12.2020 15:56
Напишите краткое содержание повести детство толстой л.н....
лиз87
30.12.2020 15:56
Какое из чисел является наименьшим : 1) е6 в 16 2)347 в 8 3)11100101 в 23)232 в 10...
Ddf001
30.12.2020 15:56
Решить уравнение 2 cos (x + п/3) = 1...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
begin
n:=1;
a:=2;
repeat
for i:=1 to n do
a:=a*2;
n:=n+1;
until a>=20;
writeln(n)
end.