В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
osadtsamax
osadtsamax
29.07.2020 18:00 •  Информатика

составить программу которая найдёт в линейном массиве сумму отрицательных элементов через генератор случайных чисел числа очень я в информатике- ноль

Показать ответ
Ответ:
lili2003love12
lili2003love12
23.01.2021 15:34

var i,s: integer;

a: array [1..10] of integer;

begin

write('Массив ');

for i:=1 to 10 do

begin

a[i]:=random(71)-30;

write (a[i]:4);

if a[i]>0 then s:=s+a[i]

end;

writeln;

write('Сумма положительных элементов массива ',s)

end.

Объяснение:

a[i]:=random(71)-30 если от -30 до 40 включительно

A[i]:= random (70)-30 если от -30 до 39 включительно

я не знаю правельна или неправельна

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота