В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Aliotu
Aliotu
25.02.2021 11:50 •  Информатика

Составить программу, которая определяет три целых числа с клавиатуры, являются ли они сторонами прямоугольного треугольника.

Показать ответ
Ответ:
Х1ега1Х
Х1ега1Х
21.07.2020 15:52
 var   
a,b,c,g : integer;   
// a,b,c - стороны         
begin 
readln (a,b,c);   

// g - находим гипотенузу (наибольшее из чисел) 
if a > b then   
begin   
if a > c then     
g := a   
else     
g := c   
end 
else   
if b > c
then   
g := b   
else   
g := c;   

// Если треугольник прямоугольный, то 
// сумма квадратов катетов равна квадрату гипотенузы      

if (sqr (a) + sqr (b) = sqr(g)) 
or (sqr (a) + sqr (c) = sqr(g)) then   
writeln ('Yes')   
else    writeln ('No');
 end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота