В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
nas81
nas81
04.06.2020 11:19 •  Информатика

Составить программу ,которая последовательно циклически запрашивает 40 целых положительных чисел и назодит минимальное значение среди чётных чисел. минимальное значение вывести на экран

Показать ответ
Ответ:
ttlekzhan
ttlekzhan
08.06.2020 03:42

program nnn;

uses crt;

var

i,m:integer;

a:array[1..40] of integer;

begin

for i:=1 to 40 do

begin

read(a[i]);

end;

m:=a[1];

for i:=1 to 40 do

begin

if a[i] mod 2 = 0 then if m>a[i] then m:=a[i];

end;

writeln(m);

end.

если без массива:

program nnn;

uses crt;

var

i,c,m:integer;

begin

for i:=1 to 40 do

begin

read(c);

if i=1 then m:=c;

if c mod 2 = 0 then if m>c then m:=c;

end;

writeln(m);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота