В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
yli2220
yli2220
08.04.2021 17:52 •  Информатика

Составить программу, которая при вводе значения показывает, нечетное ли введенное значение. Диапазон вводимых данных от 1 до 100. Используя конструкцию CASE.

Показать ответ
Ответ:
Sendula
Sendula
14.02.2020 05:12
Var i, a, s: integer;
begin
     readln(a);
     for i := a to 500 do
         s := s + i;
     writeln(s);
end.

2) 
var i, a, s, c, b: integer;
begin
     readln(a, b);
     for i := a to b do
     begin
         s := s + i;
         c := c + 1;
     end;
     writeln(s / c:4:2);
end.

3)
const N=10;
var i, b, s: integer;
    a: array [0..N] of integer;
begin
     readln(b);
     for i := 0 to N do a[i] := random(9000);
     for i := 0 to N do
         if (a[i] < b) then s := s + i;
     for i := 0 to N - 2 do
         if (a[i+1] = b) then writeln('(', a[i], '; ', a[i+2], ')');
     writeln(s);
end.

=)
0,0(0 оценок)
Ответ:
dinaumralieva
dinaumralieva
18.04.2022 01:07
Процессор- обычно его называют не слишком уважительно «камень». По сути, так оно и есть- небольшой кристалл кремния, хранящий в себе множество логических элементов, осуществляющих все нужные нам операции вычисления. В первую очередь от процессора будет зависить насколько быстр будет компьютер. Изначально процессор INTEL 4004 предназначался для… микрокалькуляторов и был изготовлен по заказу одной японской фирмы. И вскоре был выпущен первый компьютер IBM PC на основе нового микропроцессора все тои же фирмы Intel… Каждое поколение процессоров отличается не просто скоростью, но еще и формой, внешним видом и самое главное внутренним устройством, архитектурой.«Тактовая частота» является показателем скорости процессора, измеряется в мегагерцах (МГц), показывает сколько операций выполнить процессор в течение секунды. Эта величина, обозначаемая цифрой в названии процессора(например Pentium II-233)-самая важная характеристика скорости процессора. Создание новых поколений процессоров- всего лишь средство реализовать эту более высокую тактовую частоту. Но есть еще дополнительные параметры, определяющие скорость работы процессора и находятся они в «архитектуре» процессора , в его внутреннем устройстве. Один из этих параметров это КЭШ- ПАМЯТЬ. В эту память компьютер помещает все часто используемые данные, чтобы не « ходить» каждый раз к более медленной оперативной памяти и жесткому диску. По сути дела кэш- памятей на компьютере несколько, но одна- самая быстрая и маленькая, встроена в сам процессор. Это- кэш-память первого уровня. Ее размер у Pentium MMX и Pentium II одинаков и составляет два блока по 16 килобайт в каждом.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота