В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
abukaka
abukaka
29.07.2020 11:59 •  Информатика

Составить программу, которая проверяет правопис "жи", "ши" и выводит количество ошибок и исправленную строку

Показать ответ
Ответ:
аленка1опр
аленка1опр
13.07.2020 18:25
Var
a,count:longint;
s:string;
begin
writeln('введите строку');
count:=0;
read(s);
while pos('жы',s)>0 do 
begin
 inc(count);
 a:=pos('жы',s);
 delete(s,a,2);
 insert('жи',s,a)
end;
while pos('шы',s)>0 do 
begin
 inc(count);
 a:=pos('шы',s);
 delete(s,a,2);
 insert('ши',s,a)
end;
writeln(s);
writeln('всего ошибок: ',count)
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота