В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Vkomarova
Vkomarova
24.09.2020 00:05 •  Информатика

Составить программу которая r раз находит m! значение r,m заполняются генератор случайных чисел с аргументом 6

Показать ответ
Ответ:
Аманда55573
Аманда55573
08.06.2020 00:22

Объяснение:

function factorial(n:integer):integer;

var

 i, p:integer;

begin

 p:=1;

 for i:=1 to n do

   p:=p*i;

 factorial:=p;

end;

var

 r, m:integer;

 k:integer;

begin

 randomize;

 r:=random(6);

 writeln('r = ', r);

 for k:=1 to r do begin

   m:=random(6);

   writeln(m, '! = ', factorial(m));

 end;

 readln;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота