В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
frossbaf
frossbaf
05.09.2020 12:48 •  Информатика

Составить программу, которая вычисляет сумму ряда
S=3+3.6+4.2+4.8+...+п (паскаль авс нет) ​

Показать ответ
Ответ:
andreeva1979ir
andreeva1979ir
04.03.2023 05:20
PascalABC.NET 3.3.5, сборка 1659 от 09.04.2018
Внимание! Если программа не работает, обновите версию!

begin
  var n:=ReadInteger('Количество строк/столбцов в матрице:');
  Writeln('*** Исходная матрица ***');
  var a:=MatrRandom(n,n,1,50);
  a.Println(3); Writeln(3*a.ColCount*'-');
  // начало расчетов
  var s:=0;
  for var i:=0 to n-1 do s+=a[i,n-i-1];
  Writeln('1: S=',s);
  Write('2: Суммы построчно: '); a.Rows.Select(row->row.Sum).PrintLn;
  Write('3: Произведение элементов: ');
  a.ElementsByRow.Aggregate(BigInteger(1),(p,q)->p*q).PrintLn;
  var p:BigInteger:=1;
  for var i:=0 to n-1 do p*=a[i,i];
  Writeln('4: П=',p);
end.

Необходимо решение по икт pasckal 10 ! используя только знания 10 класса. 1) найти сумму элементов п
0,0(0 оценок)
Ответ:
Андрейхоттабыч
Андрейхоттабыч
25.11.2022 22:40
Возможность создавать новый документ, используя при этом шаблоны.Возможность одновременно открывать и работать не с одним числом документов.Автоматически проверять орфографию, стилистику и грамматику при вводе текста в документ.Возможность автоматические корректировать ошибки, которые больше всего повторяются в написанном.Включает в себя расширенные возможности по форматированию документа.Возможность применять стили для быстрого форматирования документа.Включает в себя удобные механизмы по работе со сносками, ссылками, колонтитулами.Позволяет включать в текст элементы, которые были созданы в других программах, входящих в Microsoft Office: электронные таблицы, графические изображения или фотографии, графику, видеоизображения, звуки и многое другое.Возможность подготавливать гипертекстовые документы Internet и простые электронные таблицы.Возможность автоматические создавать указатели и оглавление документа.Возможность для отправки готового документа сразу из Word'a по электронной почте или же другому человеку или предприятию на факс.Содержит встроенную объемную систему и мастер подсказок.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота