Составить программу на Паскале. Разработать схему алгоритма и программу, с введенного списка фамилий выведет фамилии, которые начинаются на буквы "А" и "Б".
// PascalABC.NET 3.0, сборка 1128 begin var a:=ArrRandom(70,1,100).PrintLn; Writeln('Количество элементов, кратных трем: ', a.Where(x->x mod 3=0).Count); var p:=a.OrderByDescending(x->x).Take(4).ToArray; if (p[0]=p[1]) and (p[0]=p[2]) and (p[0]<>p[3]) then Writeln('В массиве ровно три одинаковых максимальных элемента') else Writeln('В массиве не три одинаковых максимальных элемента'); Writeln('Массив, из которого удалены элементы с нечетными значениями'); a.Where(x-> not Odd(x)).PrintLn end.
1. Рабочий стол – область экрана, на которой отображаются окна (в том числе диалоговые), значки и меню.2. Окно – ограниченная (прямоугольная) часть экрана, предназначенная для выполнения одной программы или отдельной ее функции.3. Значок и ярлык (пиктограмма) – ссылка на любой элемент, доступный на компьютере или в сети, такой как программа, файл, папка, диск, веб-страница , принтер или другой компьютер.4. Кнопка – элемент, который после воздействия на него (например, выполнения пользователем щелчка кнопкой мыши) запускает некоторую последовательность действий.5. Панель – группы логически взаимосвязанных значков, элементов управления и индикации состояния операционной системы или выполняющейся программы.6. Меню – набор команд, действий, режимов, установок и т.д.7. Папка – элемент , предназначенный для группировки файлов по какому-либо признаку.8. Приложение – прикладная программа.9. Документ – самостоятельный файл, созданный в приложении и получивший при сохранении имя, с которого он будет использоваться в дальнейшем.
begin
var a:=ArrRandom(70,1,100).PrintLn;
Writeln('Количество элементов, кратных трем: ',
a.Where(x->x mod 3=0).Count);
var p:=a.OrderByDescending(x->x).Take(4).ToArray;
if (p[0]=p[1]) and (p[0]=p[2]) and (p[0]<>p[3]) then
Writeln('В массиве ровно три одинаковых максимальных элемента')
else Writeln('В массиве не три одинаковых максимальных элемента');
Writeln('Массив, из которого удалены элементы с нечетными значениями');
a.Where(x-> not Odd(x)).PrintLn
end.
Тестовое решение:
38 85 87 89 78 50 26 92 6 41 14 57 14 41 81 5 30 21 27 71 92 55 76 53 84 18 62 28 85 58 14 58 42 92 1 93 68 67 53 65 15 45 47 57 76 60 6 88 44 4 27 21 39 67 96 84 10 35 6 60 88 98 7 48 28 56 16 23 40 88
Количество элементов, кратных трем: 25
В массиве не три одинаковых максимальных элемента
Массив, из которого удалены элементы с нечетными значениями
38 78 50 26 92 6 14 14 30 92 76 84 18 62 28 58 14 58 42 92 68 76 60 6 88 44 4 96 84 10 6 60 88 98 48 28 56 16 40 88
3 76 40 20 39 100 15 85 75 58 43 48 2 57 45 90 12 50 92 70 64 33 94 38 18 59 74 10 31 13 61 34 100 77 42 61 76 95 38 100 27 44 7 75 23 22 24 52 70 39 91 68 79 74 83 70 82 2 2 80 26 6 55 62 97 10 48 25 16 84
Количество элементов, кратных трем: 19
В массиве ровно три одинаковых максимальных элемента
Массив, из которого удалены элементы с нечетными значениями
76 40 20 100 58 48 2 90 12 50 92 70 64 94 38 18 74 10 34 100 42 76 38 100 44 22 24 52 70 68 74 70 82 2 2 80 26 6 62 10 48 16 84