В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
gulchik1979g
gulchik1979g
12.07.2021 13:52 •  Информатика

составить программу на языке Паскаль. "Дано число (вводится пользователем с клавиатуры). Если число делится на 3 или оканчивается на 7, то вывести сообщение: Число удовлетворяет условию. В противном случае вывести сообщение: Заданное число не соответствует условию."

Показать ответ
Ответ:
lag228
lag228
04.06.2020 00:31
1)
#include <iostream>

using namespace std;

int main() {
  cout << "Сколько Вам лет?" << endl;
  int age;
  string s;
  cin >> age >> s;
}
2)
#include <iostream>

using namespace std;

int main() {
  cout << "Сколько Вам лет?" << endl;
  int age;
  cin >> age;
  if(age < 0) cout << "wrong" << endl;
  else if(age >= 18) cout << "yes" << endl;
  else cout << "no" << endl;
}

3)
#include <iostream>

using namespace std;

int main() {
 int a;
 cin >> a
 if(a%2 == 0) cout << "четное" << endl;
 else cout << "нечетное" << endl;
}

4)
#include <iostream>

using namespace std;

int main() {
 int a,b,c;
 string s = "";
 cin >> a >> b >> c;
 if(a == b && a == c) cout << "равносторонний" << endl;
 else {
    if (a==b || a == c || b == c) s += "равнобедренный";
    if( a*a == (b*b+c*c) || b*b == (a*a+c*c) || c*c == (a*a+b*b))
           s+= "прямоугольный";
    if(s == '') cout << "обычный" << endl;
    else cout << s << endl;
  }
}
 
 
0,0(0 оценок)
Ответ:
алина11001
алина11001
21.10.2021 13:36
Procedure TForm1.Button4Click(Sender: TObject);
var Buff: TNodePointer;
x: TItem;
i,j: Cardinal;
begin
 i:=0;
 Buff:=Head;
 if(Buff^.Next=nil) then
 begin
  ShowMessage('В стеке один элемент!');
  exit;
 end;
while Buff <> nil do
begin
 while (Buff^.Next<>nil) and (Buff^.Data=Buff^.Next^.Data) and not(isEmpty(Buff)) do
 begin
  pop(Buff^.Next,x);
  for j:=i to StringGrid1.RowCount-2 do
   StringGrid1.Cells[0,j]:=StringGrid1.Cells[0,j+1];
  StringGrid1.RowCount:=StringGrid1.RowCount-1;
 end;
 Buff:=Buff^.Next;
 i:=i+1;
end;
end;

PS. Delphi у меня сейчас нет, так что проверяйте сами. Если что не так - сообщайте.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота