Составить программу на языке паскаль для нахождения максимального элемента в массиве из 7 элементов(целых двухзначный чисел) заданного случайным образом
Program nechaeva97; uses crt; const n=7; var i,t,max:integer; begin writeln('*** alphaues is thinking... ***'); writeln('*** OK ***'); max:=random(90)+10; write (max:5); for i:=2 to n do begin t:=random(90)+10; write (t:5); if max<t then max:=t; end; writeln(); writeln('Максимальный элемент массива равен= ',max); end.
uses crt; var a:array [1..100] of integer; max,i,n:integer; begin randomize; for i:=1 to 7 do begin a[i]:=random(90)+10; write(a[i],' '); end; writeln; max:=a[1]; for i:=1 to n do if a[i]>max then max:=a[i]; write('max=',max); end.
Program nechaeva97;
uses crt;
const n=7;
var
i,t,max:integer;
begin
writeln('*** alphaues is thinking... ***');
writeln('*** OK ***');
max:=random(90)+10;
write (max:5);
for i:=2 to n do
begin
t:=random(90)+10;
write (t:5);
if max<t then max:=t;
end;
writeln();
writeln('Максимальный элемент массива равен= ',max);
end.
uses crt;
var a:array [1..100] of integer;
max,i,n:integer;
begin
randomize;
for i:=1 to 7 do
begin
a[i]:=random(90)+10;
write(a[i],' ');
end;
writeln;
max:=a[1];
for i:=1 to n do
if a[i]>max then max:=a[i];
write('max=',max);
end.