В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
maxsimsto
maxsimsto
03.03.2021 11:04 •  Информатика

Составить программу нахождения для заданного натурального числа n всех делителей, кратных числу c. формат входных данных входной файл содержит числа n, c (1≤n,c≤1000). формат выходных данных выведите искомые делители. примеры: вход 6 3 выход 3 6 вход 4 15 выход

Показать ответ
Ответ:
37Zorky
37Zorky
08.10.2020 21:14

Язык С++

#include <iostream>

using namespace std;

int main(){

int N,C;

cin>>N>>C;

for(int i=1;i<=N/C;i++)

if(N%(i*C)==0)

cout<<i*C<<" ";

return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота