В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Pacan4ikForever
Pacan4ikForever
28.02.2023 19:56 •  Информатика

Составить программу нахождения всех трехзначных чисел, таких, что сумма цифр равна а, а само число делится на в (а и в вводятся с клавиатуры).

Показать ответ
Ответ:
Амбрела123
Амбрела123
08.10.2020 04:58
Var a,b,s,q,w,e:Integer;
begin
Read(a,b);
for s:= 100 to 999 do
begin
q:= s div 100;
w:= s div 10 mod 10;
e:= s mod 10;
if (q+w+e=a) and(s mod b = 0) then
WriteLn(s);
end;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота