В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
alisalis290
alisalis290
27.05.2020 14:19 •  Информатика

Составить программу определения кислотности раствора с лакмусовой бумажки. если бумажка окрашивается в красный цвет - раствор кислотный; в синий - раствор щелочной; не меняет цвет - раствор нейтральный.

Показать ответ
Ответ:
daniladremov
daniladremov
20.05.2022 09:04

class Program

 {

   static void Main(string[] args)

   {

     string src = " Qwy. ... Asdf.. Lkjdfs A.";

     //string dest = ReplaceDots(src, '.', '…', 3);

     string dest = ReplaceDots(src, '.', "...", 3);

 

     Console.WriteLine("src:\t" + src);

     Console.WriteLine("dest:\t" + dest);

 

     Console.WriteLine();

     Console.Write("Press any key for exit ...");

     Console.ReadKey(true);

   }

 

   //private static string ReplaceDots(string src, char dotCh, char dots, int minDotsCount)

   private static string ReplaceDots(string src, char dotCh, string dots, int minDotsCount)

   {

     StringBuilder dest = new StringBuilder();

 

     int i = 0;

     while (i < src.Length)

     {

       int dotsCount = 0;

       while (i < src.Length && src[i] == dotCh)

       {

         dotsCount++;

         i++;

       }

 

       if (dotsCount >= minDotsCount)

         dest.Append(dots);

       else if (dotsCount == 0)

         dest.Append(src[i++]);

       else

         while (dotsCount-- > 0)

           dest.Append(dotCh);

     }

 

     return dest.ToString(); ;

   }

 }

0,0(0 оценок)
Ответ:

без использования всяких функций

Объяснение:

Pascal

var

 a:array [1..12] of integer;

 i, j, k:integer;

begin

 randomize;  

 for i:=1 to 12 do  

   a[i]:=random(101)-50;

 print(a);

 writeln();

 

 i:=1;

 while i <= 12 do begin

   for j:= i to 12 do

     if a[j]<a[i] then begin

       k:=a[j];

       a[j]:=a[i];

       a[i]:=k;

       dec(i);

       break;

     end;  

   inc(i);

 end;  

 print(a);

 writeln();

 

 if a[3] mod 2 = 0 then

   writeln(a[3], ' число четное')

 else

   writeln(a[3], ' число нечетное')

end.


Дан одномерный массив из 12 случайных чисел в Диапазоне [-50;50]. Отсортировать массив по возрастани
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота