В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
MimINL
MimINL
12.06.2021 11:41 •  Информатика

Составить программу, печатающую все простые числа, не превосходящие данного числа. большое.

Показать ответ
Ответ:
Cherry5858
Cherry5858
31.08.2020 22:24
Uses crt;
var k,i,n,s:integer;
istin:boolean;
label 1,2;
begin clrscr;
 k:=1;
writeln ('vvedite chislo');
readln(n);
1:n:=n;
for s:=2 to n-1 do begin if n mod s=0 then begin n:=n+1;
goto 1;
end else goto 2;
end;
2:while k<100 do begin istin:=true;
i:=3;
while (i<=trunc(sqrt(n))) and istin do if n mod i=0 then istin:=false else i:=i+2;
if istin then begin write(n,' ');
k:=k+1;
end;
 n:=n+2;
end;
readkey
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота