В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
vladka0405
vladka0405
11.11.2022 10:10 •  Информатика

Составить программу, решающую следующую : вы покупаете товар, и у вас имеются монеты номиналом 1, 2, 5, 10 рублей. наберите необходимую сумму товара в n рублей так, чтобы она состояла из минимального количества монет. язык паскаль

Показать ответ
Ответ:
ленок209
ленок209
07.08.2020 11:31
Program noname;
var a,b,c,d,e;
begin
readln(a);
b:=a div 10;
a:=a-b;
c:=a div 5;
a:=a-c;
d:=a div 2;
a:=a-d;
e:=a;
writeln('Десяток:',b);
writeln('Пятёрок:',c);
writeln('Двоек:',d);
writeln('Единиц:',e);
writeln('Всего монет:'(b+c+d+e));
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота