В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История

Составить программу решения уравнения ax=b, рассмотрев все возможные целые значения а и b.

Показать ответ
Ответ:
Fdcsxdxdvrcfcr
Fdcsxdxdvrcfcr
11.12.2022 02:23

Код на Java

import java.util.Random;

import java.util.Scanner;

public class Main {

   public static void main(String[] args) {

       Scanner in = new Scanner(System.in);

    int A[] = new int[20]; //создание массива

    for(int i=0;i<A.length;i++) {

        A[i]=in.nextInt();    //заполнение массива

       }

    int sum = 0;

    Random r = new Random(); //обьект класса Random

    for(int i=0;i<5;i++) {

        sum=sum+A[r.nextInt(20)]; //r.nextInt(20) - генерирует число от 0 до 20

       }

    System.out.println(sum);

   }

}

0,0(0 оценок)
Ответ:
ivanivankuznets
ivanivankuznets
14.05.2022 18:02

Если не разделять понятия неотрицательных и положительных, то этот код:

Var

A,B,C,P,O:integer;

Begin

P:=0;

O:=0;

WriteLn('Введи три числа');

ReadLn(A,B,C);

if A>=0 then P:=P+1

else O:=O+1;

if B>=0 then P:=P+1

else O:=O+1;

if C>=0 then P:=P+1

else O:=O+1;

WriteLn('Положительных чисел ',P);

WriteLn('Отрицательных чисел ',O)

End.

Если разделять, то этот:

Var A,B,C,P,O,N:integer;

Begin

P:=0;

O:=0;

N:=0;

WriteLn('Введи три числа');

ReadLn(A,B,C);

if A=0 then N:=N+1

else

if A>0 then P:=P+1

else O:=O+1;

if B=0 then N:=N+1

else

if B>0 then P:=P+1

else O:=O+1;

if C=0 then N:=N+1

else

if C>0 then P:=P+1

else O:=O+1;

WriteLn('Положительных чисел ',P);

WriteLn('Отрицательных чисел ',O);

WriteLn('Нулей ',N)

End.

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота