Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
shkola56
24.07.2021 20:49 •
Информатика
Составить программу с цикла repeat. составить программу выводящую и суммирующую любое количество целых чисел если введено 999 о на экран выводится результат суммирования.
Показать ответ
Ответ:
chitaevtimur134
07.08.2020 07:08
На языке Java. Программа складывает и отрицательные и положительные числа.
class SumNum{
public static void main(String args[]){
try{
long sumNum=0,numSum=new Long(new java.io.BufferedReader(new java.io.InputStreamReader(System.in)).readLine());
do sumNum+=numSum;while((numSum>0?--numSum:++numSum)!=0);System.out.print("Результат "+sumNum);
}catch(java.io.IOException io){
System.out.println(" - Ошибка ввода!\n"); main(null);
}catch(NumberFormatException nf){
System.out.println(" - Введите целочисленное значение!\n"); main(null);
}
}
}
0,0
(0 оценок)
Популярные вопросы: Информатика
Флаксария
13.07.2020 16:37
48 ! 1)произвести вывод на печать отрицательных чисел от -1 до -21. причем вывод необходимо осуществить только каждого третьего числа! 2) напишите программу используя...
mihailova1999
13.07.2020 16:37
С++ напишите программу, которая в четырехзначном числе меняет местами цифры сотен и десятков. вывести полученное число. ввод вывод 1267 1627...
Xom9l4ok
19.04.2020 22:57
А) Определить значение контрольного бита при передаче сообщения A с использованием битов четности. б) Определить контрольные и информационные биты в сообщении A методом...
зубрильчик
30.01.2021 16:42
Для какого наименьшего целого числа X ЛОЖНО высказывание: (X 73) ИЛИ НЕ (X 72) Можете объяснить как решать...
ник4760
25.02.2020 02:21
Задали по инфе сделать презентуху и, мол тема должна быть по ,непосредственно, информатике или . , понятно, отлетает. всё что нужно - тема, всю инфу я найду сам. тема...
dasha1949
25.02.2020 02:21
Файловая система это порядок на на информации. файловая система доступ к программам...
Ivanlabur
31.08.2020 20:45
Люд нужно ли соблюдать последовательность столбцов при сортировке ...
Петр1234561
17.04.2020 01:00
Каким создавали рисунки на ЭВМ до появления апаратных и программных средств компьютерной графики...
valerya7000
12.11.2021 05:17
Обращаюсь к информатикам! Составить программу в Паскале для обработки одномерного массива из 15 чисел. Значения элементов массива задать с клавиатуры самостоятельно....
Печенькавасилиса
10.04.2023 23:05
Неправильно поєднано числівник з іменником в рядку А) Двох шостих відсотка,два тролейбуси Б) Дев ять сотих гектарів,два океани В) Три сайти, п ять шостих кілограма Г)...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
class SumNum{
public static void main(String args[]){
try{
long sumNum=0,numSum=new Long(new java.io.BufferedReader(new java.io.InputStreamReader(System.in)).readLine());
do sumNum+=numSum;while((numSum>0?--numSum:++numSum)!=0);System.out.print("Результат "+sumNum);
}catch(java.io.IOException io){
System.out.println(" - Ошибка ввода!\n"); main(null);
}catch(NumberFormatException nf){
System.out.println(" - Введите целочисленное значение!\n"); main(null);
}
}
}