В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
ArtemRussia
ArtemRussia
14.03.2023 03:56 •  Информатика

Составить программу. В целочисленной последовательности есть нулевые элементы. Вывести номера этих элементов.

Показать ответ
Ответ:
PFAN
PFAN
12.02.2021 19:38

#include <iostream>

using namespace std;

int main()

{

setlocale(LC_CTYPE, "Russian");

int n;

cout << "Введите размер массива - ";

cin >> n;

int* a = new int[n];

cout << "Массив: ";

for (int i = 0; i < n; i++)

{

cin >> a[i];

}

cout << "Индексы нулевых элементов: ";

for (int i = 0; i < n; i++)

{

if (a[i] == 0)

{

cout << i<< " ";

}

}

delete []a;

return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота