Составить программу (в pascal) позволяющую найти минимальный элемент массива. подсчитать количество элементов в массиве, равных минимальному. размеренность массива произвольная.
Program my; var k,i,z:integer; a:array[1...N]:integer; begin k:=99999; for i:=1 to N do if a[i]<k then k:=a[i]; z:=0; for i:=1 to N do if a[i]=k then z:=z+1; end. =)
Uses crt; const N=10; var a:array [1..N] of integer; x,min,k:integer; begin for x:=1 to N do begin write('a[',x,']:',a[x]); readln(a[x]); end; min:=a[1]; for x:=1 to N do if a[x]<min then min:=a[x]; for x:=1 to N do if a[x]=min then inc(k); writeln('Минимальный элемент: ',min,'. Таких элементов в массиве: ',k); end.
var k,i,z:integer;
a:array[1...N]:integer;
begin
k:=99999;
for i:=1 to N do
if a[i]<k then k:=a[i];
z:=0;
for i:=1 to N do
if a[i]=k then z:=z+1;
end.
=)
const N=10;
var a:array [1..N] of integer;
x,min,k:integer;
begin
for x:=1 to N do
begin
write('a[',x,']:',a[x]);
readln(a[x]);
end;
min:=a[1];
for x:=1 to N do
if a[x]<min then min:=a[x];
for x:=1 to N do
if a[x]=min then inc(k);
writeln('Минимальный элемент: ',min,'. Таких элементов в массиве: ',k);
end.