В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Tetafir
Tetafir
20.11.2022 04:26 •  Информатика

Составить программу в паскале массив задан датчиком случайных чисел на интервале [-37, 66]. найти наибольший и наименьший элементы и их номера. размер массива произвольный, но не больше 100

Показать ответ
Ответ:
Vika20040406
Vika20040406
07.10.2020 09:47
// PascalABC.NET 3.3, сборка 1583 от 25.11.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ArrRandom(ReadInteger('n='),-37,66); a.Println;
  var (imin,imax):=(a.IndexMin,a.IndexMax);
  Writeln('Минимальный элемент №',imin+1,' равен ',a[imin]);
  Writeln('Максимальный элемент №',imax+1,' равен ',a[imax]);
end.

Пример
n= 17
17 21 49 -2 49 30 -3 39 11 20 65 -28 10 14 -30 11 -1
Минимальный элемент №15 равен -30
Максимальный элемент №11 равен 65

Составить программу в паскале массив задан датчиком случайных чисел на интервале [-37, 66]. найти на
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота