В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
romamrn
romamrn
12.02.2021 11:51 •  Информатика

Составить программу в с++ дан массив размера n и целые числа k и l (1 < k ≤ l ≤ n). найти сумму всех элементов массива, кроме элементов с номерами от k до l включительно.

Показать ответ
Ответ:
Twister04
Twister04
06.10.2020 13:06
#include <iostream>#include <iomanip>#include <ctime>
using namespace std;
int main(){ setlocale(LC_ALL, "RUSSIAN"); const int N = 10; int arr[N]; int K, L, sum = 0, sumexcl = 0; srand(time(NULL)); for (int i = 0; i < N; i++) { arr[i] = rand() % 10; sum += arr[i]; } cout << "Введите K >> "; cin >> K; cout << "Введите L >> "; cin >> L; for (int i = 0; i < N; i++) { cout << arr[i] << " "; if((i>=K) && (i<=L)) sumexcl += arr[i]; } sum -= sumexcl; cout << "Результат: " << sum << endl; system("pause");}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота