В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Arsen2045
Arsen2045
25.10.2020 17:16 •  Информатика

Составить программу вычисления среднего арифметического значение четных по значению элементов массива. элементы нумеруются с 0 до 49 и с датчика случайных чисел из диапазона [0,300]

Показать ответ
Ответ:
костров1
костров1
08.10.2020 14:38
Var a: array[0..49] of Integer; sr:real;sum,i,n: integer;beginwriteln('Исходный массив');for i:=0 to 49 do begina[i]:=Random(300);write(a[i]:4);if a[i] mod 2 = 0 then begin sum:= sum + a[i]; n:= n +1; end;end;sr:= sum / n;writeln;writeln('Cреднее арифметическое значение четных ',sr);end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота